threads / patch / 37104

v3, 2 partsalloc.c: remove the alloc_raw_commit_node() function

Subject: [PATCH v3 1/2] alloc.c: remove the alloc_raw_commit_node() function

## tl;dr

3 messages between Jul 10, 2014 and Jul 11, 2014. Diffs are folded; open one to read it.

replies: 2people: 2as markdown or json

Ramsay Jones· Jul 10, 2014, 23:58 UTC · lore

In order to encapsulate the setting of the unique commit index, commit 969eba63 ("commit: push commit_index update into alloc_commit_node", 10-06-2014) introduced a (logically private) intermediary allocator function. However, this function (alloc_raw_commit_node()) was declared as a public function, which undermines its entire purpose.

Introduce an inline function, alloc_node(), which implements the main logic of the allocator used by DEFINE_ALLOCATOR, and redefine the macro in terms of the new function. In addition, use the new function in the implementation of the alloc_commit_node() allocator, rather than the intermediary allocator, which can now be removed.

Noticed by sparse ("symbol 'alloc_raw_commit_node' was not declared. Should it be static?").

Signed-off-by: Ramsay Jones <ramsay@ramsay1.demon.co.uk>
---
 alloc.c | 47 +++++++++++++++++++++++++++++------------------
 1 file changed, 29 insertions(+), 18 deletions(-)
Show changes to alloc.c +29 −18
diff --git a/alloc.c b/alloc.c
index eb22a45..d7c3605 100644
--- a/alloc.c
+++ b/alloc.c
@@ -19,22 +19,10 @@
 #define BLOCKING 1024
 
 #define DEFINE_ALLOCATOR(name, type)				\
-static unsigned int name##_allocs;				\
+static struct alloc_state name##_state;				\
 void *alloc_##name##_node(void)					\
 {								\
-	static int nr;						\
-	static type *block;					\
-	void *ret;						\
-								\
-	if (!nr) {						\
-		nr = BLOCKING;					\
-		block = xmalloc(BLOCKING * sizeof(type));	\
-	}							\
-	nr--;							\
-	name##_allocs++;					\
-	ret = block++;						\
-	memset(ret, 0, sizeof(type));				\
-	return ret;						\
+	return alloc_node(&name##_state, sizeof(type));		\
 }
 
 union any_object {
@@ -45,16 +33,39 @@ union any_object {
 	struct tag tag;
 };
 
+struct alloc_state {
+	int count; /* total number of nodes allocated */
+	int nr;    /* number of nodes left in current allocation */
+	void *p;   /* first free node in current allocation */
+};
+
+static inline void *alloc_node(struct alloc_state *s, size_t node_size)
+{
+	void *ret;
+
+	if (!s->nr) {
+		s->nr = BLOCKING;
+		s->p = xmalloc(BLOCKING * node_size);
+	}
+	s->nr--;
+	s->count++;
+	ret = s->p;
+	s->p = (char *)s->p + node_size;
+	memset(ret, 0, node_size);
+	return ret;
+}
+
 DEFINE_ALLOCATOR(blob, struct blob)
 DEFINE_ALLOCATOR(tree, struct tree)
-DEFINE_ALLOCATOR(raw_commit, struct commit)
 DEFINE_ALLOCATOR(tag, struct tag)
 DEFINE_ALLOCATOR(object, union any_object)
 
+static struct alloc_state commit_state;
+
 void *alloc_commit_node(void)
 {
 	static int commit_count;
-	struct commit *c = alloc_raw_commit_node();
+	struct commit *c = alloc_node(&commit_state, sizeof(struct commit));
 	c->index = commit_count++;
 	return c;
 }
@@ -66,13 +77,13 @@ static void report(const char *name, unsigned int count, size_t size)
 }
 
 #define REPORT(name, type)	\
-    report(#name, name##_allocs, name##_allocs * sizeof(type) >> 10)
+    report(#name, name##_state.count, name##_state.count * sizeof(type) >> 10)
 
 void alloc_report(void)
 {
 	REPORT(blob, struct blob);
 	REPORT(tree, struct tree);
-	REPORT(raw_commit, struct commit);
+	REPORT(commit, struct commit);
 	REPORT(tag, struct tag);
 	REPORT(object, union any_object);
 }
-- 
2.0.0
Jeff King· Jul 11, 2014, 00:09 UTC · re: Ramsay Jones · lore

Re: [PATCH v3 1/2] alloc.c: remove the alloc_raw_commit_node() function

On Fri, Jul 11, 2014 at 12:58:31AM +0100, Ramsay Jones wrote:
Show 20 quoted lines
>  #define DEFINE_ALLOCATOR(name, type)				\
> -static unsigned int name##_allocs;				\
> +static struct alloc_state name##_state;				\
>  void *alloc_##name##_node(void)					\
>  {								\
> -	static int nr;						\
> -	static type *block;					\
> -	void *ret;						\
> -								\
> -	if (!nr) {						\
> -		nr = BLOCKING;					\
> -		block = xmalloc(BLOCKING * sizeof(type));	\
> -	}							\
> -	nr--;							\
> -	name##_allocs++;					\
> -	ret = block++;						\
> -	memset(ret, 0, sizeof(type));				\
> -	return ret;						\
> +	return alloc_node(&name##_state, sizeof(type));		\
>  }

Yay. Not only does this solve the problem, but it gets rid of nasty multi-line macro. In fact, I kind of wonder if we should just do away with the macro entirely, and write out:

  static struct alloc_state blob_state;
  void alloc_blob_node(void)
  {
	return alloc_node(&blob_state, sizeof(struct blob));
  }
It's more lines, but it is probably less obfuscated to a reader.
-Peff
Ramsay Jones· Jul 11, 2014, 00:33 UTC · re: Jeff King · lore

Re: [PATCH v3 1/2] alloc.c: remove the alloc_raw_commit_node() function

On 11/07/14 01:09, Jeff King wrote:
Show 34 quoted lines
> On Fri, Jul 11, 2014 at 12:58:31AM +0100, Ramsay Jones wrote:
> 
>>  #define DEFINE_ALLOCATOR(name, type)				\
>> -static unsigned int name##_allocs;				\
>> +static struct alloc_state name##_state;				\
>>  void *alloc_##name##_node(void)					\
>>  {								\
>> -	static int nr;						\
>> -	static type *block;					\
>> -	void *ret;						\
>> -								\
>> -	if (!nr) {						\
>> -		nr = BLOCKING;					\
>> -		block = xmalloc(BLOCKING * sizeof(type));	\
>> -	}							\
>> -	nr--;							\
>> -	name##_allocs++;					\
>> -	ret = block++;						\
>> -	memset(ret, 0, sizeof(type));				\
>> -	return ret;						\
>> +	return alloc_node(&name##_state, sizeof(type));		\
>>  }
> 
> Yay. Not only does this solve the problem, but it gets rid of nasty
> multi-line macro. In fact, I kind of wonder if we should just do away
> with the macro entirely, and write out:
> 
>   static struct alloc_state blob_state;
>   void alloc_blob_node(void)
>   {
> 	return alloc_node(&blob_state, sizeof(struct blob));
>   }
> 
> It's more lines, but it is probably less obfuscated to a reader.
Yeah, I'm not a fan of _large_ multi-line macros myself.

Now that DEFINE_ALLOCATOR has slimmed down, I don't mind it so much. However, I agree that doing away with the macro leads to easier to read code. (I also don't mind the extra lines).

ATB, Ramsay Jones

← back to recent threads