threads / patch / 33177

patchsetup.c: Remove duplicate code from prefix_pathspec()

Subject: [PATCH] setup.c: Remove duplicate code from prefix_pathspec()

## tl;dr

One message between Mar 14, 2013 and Mar 14, 2013. Diffs are folded; open one to read it.

replies: 0people: 1as markdown or json

Lukas Fleischer· Mar 14, 2013, 00:24 UTC · lore

Only check for ',' explicitly and handle both ')' and '\0' in the else branch. strcspn() can only return ',', ')' and '\0' at this point so the new code is completely equivalent to what we had before.

This also fixes following GCC warning:
    setup.c: In function ‘get_pathspec’:
    setup.c:207:8: warning: ‘nextat’ may be used uninitialized in this function [-Wmaybe-uninitialized]
    setup.c:205:15: note: ‘nextat’ was declared here
Signed-off-by: Lukas Fleischer <git@cryptocrack.de>
---
This removes the only warning that currently occurs when building the
next branch.
Junio: Feel free to squash this into Andrew's patch (805da4dee15b,
"setup.c: stop prefix_pathspec() from looping past the end of string").
 setup.c | 9 ++++-----
 1 file changed, 4 insertions(+), 5 deletions(-)
Show changes to setup.c +4 −5
diff --git a/setup.c b/setup.c
index d2335a8..94c1e61 100644
--- a/setup.c
+++ b/setup.c
@@ -207,12 +207,11 @@ static const char *prefix_pathspec(const char *prefix, int prefixlen, const char
 		     *copyfrom && *copyfrom != ')';
 		     copyfrom = nextat) {
 			size_t len = strcspn(copyfrom, ",)");
-			if (copyfrom[len] == '\0')
-				nextat = copyfrom + len;
-			else if (copyfrom[len] == ')')
-				nextat = copyfrom + len;
-			else if (copyfrom[len] == ',')
+			if (copyfrom[len] == ',')
 				nextat = copyfrom + len + 1;
+			else
+				/* handle ')' and '\0' */
+				nextat = copyfrom + len;
 			if (!len)
 				continue;
 			for (i = 0; i < ARRAY_SIZE(pathspec_magic); i++)
-- 
1.8.2.rc2.352.g908df73

← back to recent threads