threads / patch / 30729

patchcompat/fnmatch: Rename wchar functions to standard API

Subject: [PATCH] compat/fnmatch: Rename wchar functions to standard API

## tl;dr

One message between Jun 6, 2012 and Jun 6, 2012. Diffs are folded; open one to read it.

replies: 0people: 1as markdown or json

Vincent van Ravesteijn· Jun 6, 2012, 13:08 UTC · lore

On a platform that does not have glibc but does have 'wchar.h' or 'wctype.h', the functions '__iswctype' and '__btowc' must be renamed to standard API. If not, git cannot be compiled on the platform.

This code is taken from compat/regex/regex_internal.h.
Signed-off-by: Vincent van Ravesteijn <vfr@lyx.org>
---
 compat/fnmatch/fnmatch.c |   16 ++++++++++++----
 1 files changed, 12 insertions(+), 4 deletions(-)
Show changes to compat/fnmatch/fnmatch.c +12 −4
diff --git a/compat/fnmatch/fnmatch.c b/compat/fnmatch/fnmatch.c
index 9473aed..3f9e3d6 100644
--- a/compat/fnmatch/fnmatch.c
+++ b/compat/fnmatch/fnmatch.c
@@ -99,11 +99,19 @@
 #   define CHAR_CLASS_MAX_LENGTH 256
 #  endif
 
-#  ifdef _LIBC
-#   define IS_CHAR_CLASS(string) __wctype (string)
-#  else
-#   define IS_CHAR_CLASS(string) wctype (string)
+/* Rename to standard API for using out of glibc.  */
+#  ifndef _LIBC
+#   ifdef __wctype
+#    undef __wctype
+#   endif
+#   define __wctype wctype
+#   ifdef __iswctype
+#    undef __iswctype
+#   endif
+#   define __iswctype iswctype
+#   define __btowc btowc
 #  endif
+#  define IS_CHAR_CLASS(string) __wctype (string)
 # else
 #  define CHAR_CLASS_MAX_LENGTH  6 /* Namely, `xdigit'.  */
 
-- 
1.7.9.msysgit.0

← back to recent threads