threads / patch / 30002

patchUse SSH key from `GIT_SSH_KEY` variable if supplied

Subject: [PATCH] Use SSH key from `GIT_SSH_KEY` variable if supplied

## tl;dr

4 messages between Mar 20, 2012 and Mar 20, 2012. Diffs are folded; open one to read it.

replies: 3people: 3as markdown or json

Maciej Małecki· Mar 20, 2012, 01:39 UTC · lore

Using a different SSH key for various SSH commands seems to be a recurring theme. Allow user to supply path to the SSH key he wants to use for operations that require it without need to use `GIT_SSH` variable and a wrapper script.

Signed-off-by: Maciej Małecki <me@mmalecki.com>
---
 connect.c |   10 +++++++++-
 1 files changed, 9 insertions(+), 1 deletions(-)
Show changes to connect.c +9 −1
diff --git a/connect.c b/connect.c
index 912cdde..dd3489d 100644
--- a/connect.c
+++ b/connect.c
@@ -575,8 +575,9 @@ struct child_process *git_connect(int fd[2], const char *url_orig,
 		die("command line too long");
 
 	conn->in = conn->out = -1;
-	conn->argv = arg = xcalloc(7, sizeof(*arg));
+	conn->argv = arg = xcalloc(9, sizeof(*arg));
 	if (protocol == PROTO_SSH) {
+		const char *key;
 		const char *ssh = getenv("GIT_SSH");
 		int putty = ssh && strcasestr(ssh, "plink");
 		if (!ssh) ssh = "ssh";
@@ -589,6 +590,13 @@ struct child_process *git_connect(int fd[2], const char *url_orig,
 			*arg++ = putty ? "-P" : "-p";
 			*arg++ = port;
 		}
+
+		key = getenv("GIT_SSH_KEY");
+		if (key) {
+			*arg++ = "-i";
+			*arg++ = key;
+		}
+
 		*arg++ = host;
 	}
 	else {
-- 
1.7.7.4
Junio C Hamano· Mar 20, 2012, 01:55 UTC · re: Maciej Małecki · lore

Re: [PATCH] Use SSH key from `GIT_SSH_KEY` variable if supplied

Maciej Małecki <me@mmalecki.com> writes:
Show 15 quoted lines
>  	if (protocol == PROTO_SSH) {
> +		const char *key;
>  		const char *ssh = getenv("GIT_SSH");
>  		int putty = ssh && strcasestr(ssh, "plink");
>  		if (!ssh) ssh = "ssh";
> @@ -589,6 +590,13 @@ struct child_process *git_connect(int fd[2], const char *url_orig,
>  			*arg++ = putty ? "-P" : "-p";
>  			*arg++ = port;
>  		}
> +
> +		key = getenv("GIT_SSH_KEY");
> +		if (key) {
> +			*arg++ = "-i";
> +			*arg++ = key;
> +		}
Hmm. I am somewhat torn.

The minimalist in me finds this extraneous and unnecessary noise. Why should the user always set GIT_SSH_KEY environment variable that only applies to git and does not help his other ssh sessions? Why isn't having an entry in .ssh/config to name IdentityFile sufficient?

On the other hand, the feature-creepist in me finds this somewhat lacking. Why should we give special treatment only to "-i $identity_file" option [*1*] and not others? Do we have to invent new environment variables if we wanted to pass "-c $cipher_spec", "-l $login_name", "-I $pkcs11", "-4", "-6", or "-b $bind_address"?

Would GIT_SSH_ARGS='-i /home/me/.ssh/there.pub -l me' be more appropriate?
[Footnote]

*1* In any case, GIT_SSH_KEY is misnamed. It should match whatever word ssh(1) uses to describe the concept--in this case, it is "identity file".

Robin H. Johnson· Mar 20, 2012, 02:07 UTC · re: Junio C Hamano · lore

Re: [PATCH] Use SSH key from `GIT_SSH_KEY` variable if supplied

On Mon, Mar 19, 2012 at 06:55:06PM -0700,  Junio C Hamano wrote:
Show 8 quoted lines
> Hmm. I am somewhat torn.
> 
> The minimalist in me finds this extraneous and unnecessary noise.  Why
> should the user always set GIT_SSH_KEY environment variable that only
> applies to git and does not help his other ssh sessions?  Why isn't having
> an entry in .ssh/config to name IdentityFile sufficient?
> 
> Would GIT_SSH_ARGS='-i /home/me/.ssh/there.pub -l me' be more appropriate?

I'd strongly prefer a generic args support, for making it easier to use in deployment code.

-- 
Robin Hugh Johnson
Gentoo Linux: Developer, Trustee & Infrastructure Lead
E-Mail     : robbat2@gentoo.org
GnuPG FP   : 11ACBA4F 4778E3F6 E4EDF38E B27B944E 34884E85
Maciej Małecki· Mar 20, 2012, 08:07 UTC · re: Robin H. Johnson · lore

Re: [PATCH] Use SSH key from `GIT_SSH_KEY` variable if supplied

W dniu 20 marca 2012 03:07 użytkownik Robin H. Johnson <robbat2@gentoo.org> napisał:

Show 11 quoted lines
> On Mon, Mar 19, 2012 at 06:55:06PM -0700,  Junio C Hamano wrote:
>> Hmm. I am somewhat torn.
>>
>> The minimalist in me finds this extraneous and unnecessary noise.  Why
>> should the user always set GIT_SSH_KEY environment variable that only
>> applies to git and does not help his other ssh sessions?  Why isn't having
>> an entry in .ssh/config to name IdentityFile sufficient?
>>
>> Would GIT_SSH_ARGS='-i /home/me/.ssh/there.pub -l me' be more appropriate?
> I'd strongly prefer a generic args support, for making it easier to use
> in deployment code.

After rethinking it, I'm also +1 on GIT_SSH_ARGS. Should I submit a patch? Sorry for noob question, but it'd go into a new e-mail thread, right?

← back to recent threads