# [PATCH v2] wt-status.c: Increase code readability.

2 messages from 2011-04-26 to 2011-04-26. Participants: Henrik Hautakoski, Junio C Hamano.
Thread: https://gitlist.dev/t/27185

## Henrik Hautakoski, 2011-04-26 11:26

Subject: [PATCH v2] wt-status.c: Increase code readability.
Message-ID: <1303817198-23347-1-git-send-email-henrik@fiktivkod.org>
URL: https://gitlist.dev/e/1303817198-23347-1-git-send-email-henrik%40fiktivkod.org

```
Some if/else statements has braces on only some branches. Be consistent and make
all branches have braces.

Signed-off-by: Henrik Hautakoski <henrik@fiktivkod.org>
---
 wt-status.c |   26 ++++++++++++++------------
 1 files changed, 14 insertions(+), 12 deletions(-)

diff --git a/wt-status.c b/wt-status.c
index 9f4e0ba..722987b 100644
--- a/wt-status.c
+++ b/wt-status.c
@@ -448,9 +448,9 @@ static void wt_status_collect_changes_initial(struct wt_status *s)
 		if (ce_stage(ce)) {
 			d->index_status = DIFF_STATUS_UNMERGED;
 			d->stagemask |= (1 << (ce_stage(ce) - 1));
-		}
-		else
+		} else {
 			d->index_status = DIFF_STATUS_ADDED;
+		}
 	}
 	free_pathspec(&pathspec);
 }
@@ -745,35 +745,37 @@ void wt_status_print(struct wt_status *s)
 		wt_status_print_other(s, &s->untracked, _("Untracked"), "add");
 		if (s->show_ignored_files)
 			wt_status_print_other(s, &s->ignored, _("Ignored"), "add -f");
-	} else if (s->commitable)
+	} else if (s->commitable) {
 		status_printf_ln(s, GIT_COLOR_NORMAL, _("Untracked files not listed%s"),
 			advice_status_hints
 			? _(" (use -u option to show untracked files)") : "");
+	}
 
 	if (s->verbose)
 		wt_status_print_verbose(s);
 	if (!s->commitable) {
-		if (s->amend)
+		if (s->amend) {
 			status_printf_ln(s, GIT_COLOR_NORMAL, _("No changes"));
-		else if (s->nowarn)
+		} else if (s->nowarn) {
 			; /* nothing */
-		else if (s->workdir_dirty)
+		} else if (s->workdir_dirty) {
 			printf(_("no changes added to commit%s\n"),
 				advice_status_hints
 				? _(" (use \"git add\" and/or \"git commit -a\")") : "");
-		else if (s->untracked.nr)
+		} else if (s->untracked.nr) {
 			printf(_("nothing added to commit but untracked files present%s\n"),
 				advice_status_hints
 				? _(" (use \"git add\" to track)") : "");
-		else if (s->is_initial)
+		} else if (s->is_initial) {
 			printf(_("nothing to commit%s\n"), advice_status_hints
 				? _(" (create/copy files and use \"git add\" to track)") : "");
-		else if (!s->show_untracked_files)
+		} else if (!s->show_untracked_files) {
 			printf(_("nothing to commit%s\n"), advice_status_hints
 				? _(" (use -u to show untracked files)") : "");
-		else
+		} else {
 			printf(_("nothing to commit%s\n"), advice_status_hints
 				? _(" (working directory clean)") : "");
+		}
 	}
 }
 
@@ -878,9 +880,9 @@ static void wt_shortstatus_print_tracking(struct wt_status *s)
 		return;
 	branch_name = s->branch;
 
-	if (!prefixcmp(branch_name, "refs/heads/"))
+	if (!prefixcmp(branch_name, "refs/heads/")) {
 		branch_name += 11;
-	else if (!strcmp(branch_name, "HEAD")) {
+	} else if (!strcmp(branch_name, "HEAD")) {
 		branch_name = _("HEAD (no branch)");
 		branch_color_local = color(WT_STATUS_NOBRANCH, s);
 	}
-- 
1.7.3.4

```

## Junio C Hamano, 2011-04-26 17:13

Subject: Re: [PATCH v2] wt-status.c: Increase code readability.
Message-ID: <7vei4pey1b.fsf@alter.siamese.dyndns.org>
URL: https://gitlist.dev/e/7vei4pey1b.fsf%40alter.siamese.dyndns.org
In-Reply-To: <1303817198-23347-1-git-send-email-henrik@fiktivkod.org>

```
Henrik Hautakoski <henrik@fiktivkod.org> writes:

> Some if/else statements has braces on only some branches. Be consistent and make
> all branches have braces.
>
> Signed-off-by: Henrik Hautakoski <henrik@fiktivkod.org>

While I agree that this patch makes things consistent, and consistency may
be good, but "readable" is more subjective.

Perhaps retitle it to "Subject: wt-status.c: style fixes"?  That would be
more consistent (no pun intended) with the body of the message.

Please hold onto this patch, and make it the first one in the series of
whatever you are planning to do to wt-status.c that you mentioned.

```
