threads / discuss / 19985

run_hook: why special check for uncaught signal?

Subject: run_hook: why special check for uncaught signal?

## tl;dr

2 messages between Jun 30, 2009 and Jul 1, 2009.

replies: 1people: 2as markdown or json

Johannes Sixt· Jun 30, 2009, 20:31 UTC · lore
Function run_hook (in run-command.c) has this check:
	ret = finish_command(&hook);
	if (ret == -ERR_RUN_COMMAND_WAITPID_SIGNAL)
		warning("%s exited due to uncaught signal", argv[0]);
	return ret;

The lines were moved to this location by ae98a008 (Move run_hook() from builtin-commit.c into run-command.c (libgit), 2009-01-16). Before this commit, the check existed in builtin-gc.c. It was introduced by bde30540 (git-gc --auto: add pre-auto-gc hook, 2008-04-09).

Why is this check necessary?

I'm asking because I'm working on a modification that would remove ERR_RUN_COMMAND_WAITPID_SIGNAL.

-- Hannes
Miklos Vajna· Jul 1, 2009, 09:57 UTC · re: Johannes Sixt · lore

Re: run_hook: why special check for uncaught signal?

On Tue, Jun 30, 2009 at 10:31:45PM +0200, Johannes Sixt <j6t@kdbg.org> wrote:
Show 13 quoted lines
> Function run_hook (in run-command.c) has this check:
> 
> 	ret = finish_command(&hook);
> 	if (ret == -ERR_RUN_COMMAND_WAITPID_SIGNAL)
> 		warning("%s exited due to uncaught signal", argv[0]);
> 	return ret;
> 
> The lines were moved to this location by ae98a008 (Move run_hook() from 
> builtin-commit.c into run-command.c (libgit), 2009-01-16). Before this 
> commit, the check existed in builtin-gc.c. It was introduced by bde30540 
> (git-gc --auto: add pre-auto-gc hook, 2008-04-09).
> 
> Why is this check necessary?

I do not really remember, but I think I wanted to give some error messages for each return code, and somehow left out ERR_RUN_COMMAND_WAITPID, ERR_RUN_COMMAND_WAITPID_WRONG_PID and ERR_RUN_COMMAND_WAITPID_NOEXIT.

> I'm asking because I'm working on a modification that would remove 
> ERR_RUN_COMMAND_WAITPID_SIGNAL.

That's fine, I think ideally run_hook() should call warning() for each case which may be returned. Such functionality is already available in builtin-receive-pack.c::hook_status() and unpack(), probably it would make sense to introduce some run_command_strerror() to avoid code duplication.

Sadly I don't have time to implement this in the near future.

← back to recent threads