threads / patch / 18609

patch, 4 partsquote: implement "sq_dequote_many" to unwrap many args in one string

Subject: [PATCH 1/4] quote: implement "sq_dequote_many" to unwrap many args in one string

## tl;dr

4 messages between Mar 29, 2009 and Mar 31, 2009. Diffs are folded; open one to read it.

replies: 3people: 2as markdown or json

Christian Couder· Mar 29, 2009, 09:44 UTC · lore

The new "sq_dequote_many" function is implemented by changing the code of "sq_dequote" and "sq_dequote" is now a thin wrapper around "sq_dequote_many".

Signed-off-by: Christian Couder <chriscool@tuxfamily.org>
---
 quote.c |   18 ++++++++++++++++--
 quote.h |    8 ++++++++
 2 files changed, 24 insertions(+), 2 deletions(-)
Show changes to 2 files +24 −2

quote.c, quote.h

diff --git a/quote.c b/quote.c
index 6a52085..8cf0ef4 100644
--- a/quote.c
+++ b/quote.c
@@ -72,7 +72,7 @@ void sq_quote_argv(struct strbuf *dst, const char** argv, size_t maxlen)
 	}
 }
 
-char *sq_dequote(char *arg)
+char *sq_dequote_many(char *arg, char **next)
 {
 	char *dst = arg;
 	char *src = arg;
@@ -92,6 +92,8 @@ char *sq_dequote(char *arg)
 		switch (*++src) {
 		case '\0':
 			*dst = 0;
+			if (next)
+				*next = 0;
 			return arg;
 		case '\\':
 			c = *++src;
@@ -101,11 +103,23 @@ char *sq_dequote(char *arg)
 			}
 		/* Fallthrough */
 		default:
-			return NULL;
+			if (!next || !isspace(*src))
+				return NULL;
+			do {
+				c = *++src;
+			} while (isspace(c));
+			*dst = 0;
+			*next = src;
+			return arg;
 		}
 	}
 }
 
+char *sq_dequote(char *arg)
+{
+	return sq_dequote_many(arg, NULL);
+}
+
 /* 1 means: quote as octal
  * 0 means: quote as octal if (quote_path_fully)
  * -1 means: never quote
diff --git a/quote.h b/quote.h
index c5eea6f..c2f98e7 100644
--- a/quote.h
+++ b/quote.h
@@ -39,6 +39,14 @@ extern void sq_quote_argv(struct strbuf *, const char **argv, size_t maxlen);
  */
 extern char *sq_dequote(char *);
 
+/*
+ * Same as the above, but can unwraps many arguments in the same string
+ * separated by space. "next" is changed to point to the next argument
+ * that should be passed as first parameter. When there are no more
+ * arguments to be dequoted, then "next" is changed to point to NULL.
+ */
+extern char *sq_dequote_many(char *arg, char **next);
+
 extern int unquote_c_style(struct strbuf *, const char *quoted, const char **endp);
 extern size_t quote_c_style(const char *name, struct strbuf *, FILE *, int no_dq);
 extern void quote_two_c_style(struct strbuf *, const char *, const char *, int);
-- 
1.6.2.1.404.gb0085.dirty
Junio C Hamano· Mar 30, 2009, 06:45 UTC · re: Christian Couder · lore

Re: [PATCH 1/4] quote: implement "sq_dequote_many" to unwrap many args in one string

Christian Couder <chriscool@tuxfamily.org> writes:
Show 6 quoted lines
> @@ -92,6 +92,8 @@ char *sq_dequote(char *arg)
>  		switch (*++src) {
>  		case '\0':
>  			*dst = 0;
> +			if (next)
> +				*next = 0;
	*next = NULL;
>  			return arg;
>  		case '\\':
>  			c = *++src;
Show 10 quoted lines
> diff --git a/quote.h b/quote.h
> index c5eea6f..c2f98e7 100644
> --- a/quote.h
> +++ b/quote.h
> @@ -39,6 +39,14 @@ extern void sq_quote_argv(struct strbuf *, const char **argv, size_t maxlen);
>   */
>  extern char *sq_dequote(char *);
>  
> +/*
> + * Same as the above, but can unwraps many arguments in the same string
"can unwrap"
Show 9 quoted lines
> + * separated by space. "next" is changed to point to the next argument
> + * that should be passed as first parameter. When there are no more
> + * arguments to be dequoted, then "next" is changed to point to NULL.
> + */
> +extern char *sq_dequote_many(char *arg, char **next);
> +
>  extern int unquote_c_style(struct strbuf *, const char *quoted, const char **endp);
>  extern size_t quote_c_style(const char *name, struct strbuf *, FILE *, int no_dq);
>  extern void quote_two_c_style(struct strbuf *, const char *, const char *, int);

I think dequote_many() is misnamed, as it only does one but has a slightly more helpful interface than the bare sq_dequote() when the caller is willing to dequote many. It probably should be called dequote_step().

But do not send in replacements just yet.
Christian Couder· Mar 31, 2009, 05:04 UTC · re: Junio C Hamano · lore

Re: [PATCH 1/4] quote: implement "sq_dequote_many" to unwrap many args in one string

Le lundi 30 mars 2009, Junio C Hamano a écrit :
Show 45 quoted lines
> Christian Couder <chriscool@tuxfamily.org> writes:
> > @@ -92,6 +92,8 @@ char *sq_dequote(char *arg)
> >  		switch (*++src) {
> >  		case '\0':
> >  			*dst = 0;
> > +			if (next)
> > +				*next = 0;
>
> 	*next = NULL;
>
> >  			return arg;
> >  		case '\\':
> >  			c = *++src;
> >
> >
> >
> > diff --git a/quote.h b/quote.h
> > index c5eea6f..c2f98e7 100644
> > --- a/quote.h
> > +++ b/quote.h
> > @@ -39,6 +39,14 @@ extern void sq_quote_argv(struct strbuf *, const
> > char **argv, size_t maxlen); */
> >  extern char *sq_dequote(char *);
> >
> > +/*
> > + * Same as the above, but can unwraps many arguments in the same
> > string
>
> "can unwrap"
>
> > + * separated by space. "next" is changed to point to the next argument
> > + * that should be passed as first parameter. When there are no more
> > + * arguments to be dequoted, then "next" is changed to point to NULL.
> > + */
> > +extern char *sq_dequote_many(char *arg, char **next);
> > +
> >  extern int unquote_c_style(struct strbuf *, const char *quoted, const
> > char **endp); extern size_t quote_c_style(const char *name, struct
> > strbuf *, FILE *, int no_dq); extern void quote_two_c_style(struct
> > strbuf *, const char *, const char *, int);
>
> I think dequote_many() is misnamed, as it only does one but has a
> slightly more helpful interface than the bare sq_dequote() when the
> caller is willing to dequote many.  It probably should be called
> dequote_step().

Yeah, you are right. But you might want to change the function name in the patch title too.

Thanks, Christian.

Junio C Hamano· Mar 31, 2009, 05:09 UTC · re: Christian Couder · lore

Re: [PATCH 1/4] quote: implement "sq_dequote_many" to unwrap many args in one string

Christian Couder <chriscool@tuxfamily.org> writes:
> But you might want to change the function name in the 
> patch title too.
Thanks, sure I might ;-)

← back to recent threads