threads / discuss / 18367

What's in git.git (Mar 2009, #05; Tue, 17)

Subject: What's in git.git (Mar 2009, #05; Tue, 17)

## tl;dr

One message between Mar 18, 2009 and Mar 18, 2009.

replies: 0people: 1as markdown or json

Junio C Hamano· Mar 18, 2009, 05:41 UTC · lore

Notable topics graduated are Jay's "git remote" improvements, Kjetil's "git checkout" optimization, and René's "git grep --color".

Post 1.6.2 cycle seems to be nicely progressing, and with another mass graduation like this hopefully we can go into pre-release freeze for the next release fairly soon.

* The 'master' branch has these since the last announcement
  in addition to what are already in v1.6.2.1.
Alex Riesen (1):
  disable post-checkout test on Cygwin
Benjamin Kramer (1):
  Fix various dead stores found by the clang static analyzer
Brian Gernhardt (2):
  Create USE_ST_TIMESPEC and turn it on for Darwin
  Makefile: Set compiler switch for USE_NSEC
Chris Johnsen (2):
  git-push.txt: describe how to default to pushing only current branch
  Documentation: remove extra quoting/emphasis around literal texts
Daniel Barkalow (1):
  Give error when no remote is configured
Emil Sit (1):
  config.txt: Describe special 'none' handling in core.gitProxy.
Jay Soffian (18):
  move duplicated get_local_heads() to remote.c
  move duplicated ref_newer() to remote.c
  move locate_head() to remote.c
  remote: simplify guess_remote_head()
  remote: make copy_ref() perform a deep copy
  remote: let guess_remote_head() optionally return all matches
  remote: make match_refs() copy src ref before assigning to peer_ref
  remote: make match_refs() not short-circuit
  string-list: new for_each_string_list() function
  builtin-remote: refactor duplicated cleanup code
  builtin-remote: remove unused code in get_ref_states
  builtin-remote: rename variables and eliminate redundant function call
  builtin-remote: make get_remote_ref_states() always populate
    states.tracked
  builtin-remote: fix two inconsistencies in the output of "show <remote>"
  builtin-remote: teach show to display remote HEAD
  builtin-remote: add set-head subcommand
  builtin-remote: new show output style
  builtin-remote: new show output style for push refspecs
Jeff King (5):
  test scripts: refactor start_httpd helper
  add basic http clone/fetch tests
  refactor find_ref_by_name() to accept const list
  remote: make guess_remote_head() use exact HEAD lookup if it is available
  ls-files: require worktree when --deleted is given
Johannes Schindelin (2):
  rsync transport: allow local paths, and fix tests
  winansi: support ESC [ K (erase in line)
Johannes Sixt (1):
  recv_sideband: Bands #2 and #3 always go to stderr
Junio C Hamano (6):
  builtin-remote.c: no "commented out" code, please
  Not all systems use st_[cm]tim field for ns resolution file timestamp
  grep: cast printf %.*s "precision" argument explicitly to int
  read-tree A B C: do not create a bogus index and do not segfault
  Remove total confusion from git-fetch and git-push
  Update draft release notes to 1.6.3
Kjetil Barvik (17):
  lstat_cache(): small cleanup and optimisation
  lstat_cache(): generalise longest_match_lstat_cache()
  lstat_cache(): swap func(length, string) into func(string, length)
  unlink_entry(): introduce schedule_dir_for_removal()
  create_directories(): remove some memcpy() and strchr() calls
  write_entry(): cleanup of some duplicated code
  write_entry(): use fstat() instead of lstat() when file is open
  show_patch_diff(): remove a call to fstat()
  lstat_cache(): print a warning if doing ping-pong between cache types
  check_updates(): effective removal of cache entries marked CE_REMOVE
  fix compile error when USE_NSEC is defined
  make USE_NSEC work as expected
  verify_uptodate(): add ce_uptodate(ce) test
  write_index(): update index_state->timestamp after flushing to disk
  Record ns-timestamps if possible, but do not use it without USE_NSEC
  checkout bugfix: use stat.mtime instead of stat.ctime in two places
  Revert "lstat_cache(): print a warning if doing ping-pong between cache
    types"
Michael J Gruber (1):
  git-branch.txt: document -f correctly
Miklos Vajna (1):
  Tests: use test_cmp instead of diff where possible
Nguyễn Thái Ngọc Duy (1):
  grep: prefer builtin over external one when coloring results
Petr Kodl (2):
  MinGW: a helper function that translates Win32 API error codes
  MinGW: a hardlink implementation
René Scharfe (6):
  grep: micro-optimize hit collection for AND nodes
  grep: remove grep_opt argument from match_expr_eval()
  grep: add pmatch and eflags arguments to match_one_pattern()
  grep: color patterns in output
  grep: add support for coloring with external greps
  pickaxe: count regex matches only once
Stephen Boyd (1):
  git-send-email.txt: describe --compose better
Thomas Rast (2):
  send-email: respect in-reply-to regardless of threading
  send-email: test --no-thread --in-reply-to combination

← back to recent threads