# [PATCH 3/3] rename SHA1_FILE_DIRECTORY

1 messages from 2005-04-20 to 2005-04-20. Participants: Zach Welch.
Thread: https://gitlist.dev/t/161

## Zach Welch, 2005-04-20 04:32

Subject: [PATCH 3/3] rename SHA1_FILE_DIRECTORY
Message-ID: <mailbox-1370-1113971526-299194@spoon>
URL: https://gitlist.dev/e/mailbox-1370-1113971526-299194%40spoon

```
This patch applies on top of:
        [PATCH 1/3] add GIT_CACHE_DIRECTORY support
        [PATCH 2/3] rename object directory symbols

 cache.h |    2 +-
 1 files changed, 1 insertion(+), 1 deletion(-)

Signed-Off-By: Zach Welch <zw@superlucidity.net>

Rename SHA1_FILE_DIRECTORY to GIT_OBJECT_DIRECTORY.  Scripts that
used to pass this setting will need to be updated.

cache.h: 218bec12fab3fb57ad03fafccedd4398c64c3646
--- a/cache.h
+++ b/cache.h
@@ -84,7 +84,7 @@ unsigned int active_nr, active_alloc;
 #define GIT_CACHE_ENVIRONMENT "GIT_CACHE_DIRECTORY"
 #define DEFAULT_GIT_CACHE_ENVIRONMENT ".git"
 
-#define GIT_OBJECT_ENVIRONMENT "SHA1_FILE_DIRECTORY"
+#define GIT_OBJECT_ENVIRONMENT "GIT_OBJECT_DIRECTORY"
 #define DEFAULT_GIT_OBJECT_ENVIRONMENT ".git/objects"
 
 #define alloc_nr(x) (((x)+16)*3/2)

```
