threads / patch / 15829

patchCleanup in sha1_file.c::cache_or_unpack_entry()

Subject: [PATCH] Cleanup in sha1_file.c::cache_or_unpack_entry()

## tl;dr

One message between Oct 9, 2008 and Oct 9, 2008. Diffs are folded; open one to read it.

replies: 0people: 1as markdown or json

Miklos Vajna· Oct 9, 2008, 00:11 UTC · lore

This patch just removes an unnecessary goto which makes the code easier to read and shorter.

Signed-off-by: Miklos Vajna <vmiklos@frugalware.org>
---
 sha1_file.c |    6 ++----
 1 files changed, 2 insertions(+), 4 deletions(-)
Show changes to sha1_file.c +2 −4
diff --git a/sha1_file.c b/sha1_file.c
index 7515987..ea6bd99 100644
--- a/sha1_file.c
+++ b/sha1_file.c
@@ -1571,11 +1571,9 @@ static void *cache_or_unpack_entry(struct packed_git *p, off_t base_offset,
 	struct delta_base_cache_entry *ent = delta_base_cache + hash;
 
 	ret = ent->data;
-	if (ret && ent->p == p && ent->base_offset == base_offset)
-		goto found_cache_entry;
-	return unpack_entry(p, base_offset, type, base_size);
+	if (!ret || ent->p != p || ent->base_offset != base_offset)
+		return unpack_entry(p, base_offset, type, base_size);
 
-found_cache_entry:
 	if (!keep_cache) {
 		ent->data = NULL;
 		ent->lru.next->prev = ent->lru.prev;
-- 
1.6.0.2

← back to recent threads