From: Junio C Hamano Date: Tue, 28 Jul 2015 15:43:38 GMT Subject: Re: [RFC/PATCH 01/11] ref-filter: add "%(objectname:size=X)" option Message-ID: In-Reply-To: <1438066594-5620-1-git-send-email-Karthik.188@gmail.com> Karthik Nayak writes: > From: Karthik Nayak > > Add support for %(objectname:size=X) where X is a number. > This will print the first X characters of an objectname. > The minimum value for X is 5. Hence any value lesser than > 5 will default to 5 characters. Is the reason why you do not call this "abbrev" because you are allowing it to truncate to a non-unique prefix? If so, wouldn't it make more sense to treat this kind of string function in a way very similar to your earlier "padright"? I.e. "%(maxwidth:5)%(objectname)" or something? If not, and if this is really an abbrev, then it makes sense to make it specific to the objectname, e.g. "%(objectname:abbrev=7)".