From: Junio C Hamano Date: Fri, 18 Jan 2019 17:36:32 GMT Subject: Re: [PATCH v2 1/3] Move init_skiplist() outside of fsck Message-ID: In-Reply-To: <87k1j247ui.fsf@evledraar.gmail.com> Ævar Arnfjörð Bjarmason writes: > On Thu, Jan 17 2019, Barret Rhoden wrote: > >> - die("Could not open skip list: %s", path); >> [...] >> + die("Could not open skip list: %s", path); > > You're just moving this around, but now that this has two uses let's say > "Could not open SHA-1 list; %s" or something like that. > >> + die("Invalid SHA-1: %s", sb.buf); > > Unlike Johannes I think it's fine to leave this. This file-format is > SHA-1 only now. We can cross the bridge of making it (and others) > SHA-256 somehow when we come to that, whether that'll be allowing > variable width or a different file. I tend to agree. The Documentation/glossary-contents.txt makes it clear that "object name" is the most formal term to use here, with synonyms like "object identifier" and much less formal "hash". For now, "SHA-1" is good enough, even though "object name" is acceptable if we really want to future-proof. But I would suspect that people would colloquially keep saying Shaah-one even when we start using different hash function(s), so such a future-proofing may not be worth it ;-)