From: Junio C Hamano Date: Tue, 03 Dec 2013 18:21:35 GMT Subject: Re: [PATCH 1/1] tests: fix gzip with exported GZIP variable in environment Message-ID: In-Reply-To: <20131203131812.GC26667@sigill.intra.peff.net> Jeff King writes: > There are a few options I see: > > 1. Drop $GZIP variable, and hard-code the prerequisite check to > "gzip", which is what is being tested. > > 2. Keep $GZIP (but rename it to $GIT_GZIP), and explicitly set up > tar.tgz.command as "$GIT_GZIP -cn". > > 3. Teach the Makefile a knob to set the value for "gzip" at compile > time, and use that for the baked-in config (and propagate it to the > test to check the prerequisite). > > I think I'd be in favor of (1). It's the simplest, and we have not seen > any reports of people who do not actually have gzip called "gzip". Users > can still override it via config if they really want to. I am OK with (1). A related tangent is that we may have to worry about is how/if a random setting coming from GZIP in the environment (e.g. "GZIP=-1v") would interfere with the test. It may be the simplest to unset $GZIP at the beginning of these tests, regardless of which of the above three is taken.