From: Junio C Hamano Date: Fri, 18 Sep 2020 18:16:54 GMT Subject: Re: [PATCH 2/4] builtin/rev-parse: learn --null-oid Message-ID: In-Reply-To: <20200918141614.GC1602321@nand.local> Taylor Blau writes: > In either case, I think '--zero-oid' makes more sense than '--null-oid' > (and it matches the tests that are already written). The pair > '--zero-oid' and '--empty-oid=' make sense to me. I am not sure rev-parse should even know about "empty-oid". An end user or a script who wants to learn what name an empty blob has can and should ask "git hash-object -t blob --stdin