From: Junio C Hamano Date: Mon, 23 Nov 2020 22:41:54 GMT Subject: Re: [PATCH v2 4/7] config: add --fixed-value option, un-implemented Message-ID: In-Reply-To: <20201123215122.GD499823@google.com> Emily Shaffer writes: >> OPT_BIT('l', "list", &actions, N_("list all"), ACTION_LIST), >> + OPT_BOOL(0, "fixed-value", &fixed_value, N_("use string equality when matching values")), > I'm not sure how to feel about this phrasing. I wonder if it would be > clearer to say something like 'treat 'value_regex' as a literal string > instead'? Hmmm. Update the document and help text with s/value_regex/value_pattern/ and say "use value_pattern as a fixed string, not an extended regexp", perhaps? > /* If set, ensure 'value_regex' was provided also */ > if (fixed_value) { > ... > /* 'git config --unset-all ' */ > case ACTION_UNSET_ALL: Nice.