From: Junio C Hamano Date: Mon, 18 Jan 2016 19:55:18 GMT Subject: Re: [PATCH 1/6] shortlog: match both "Author:" and "author" on stdin Message-ID: In-Reply-To: <20160118192621.GA981@sigill.intra.peff.net> Jeff King writes: > So it's not wrong, but it's perhaps more complicated than it needs to > be. We could scrap this patch in favor of just: > > if (!skip_prefix(author, "Author: ", &v) && > !skip_prefix(author, "author ", &v)) > continue; > > That is technically more strict (it does not take "author: ", which is > accepted by the current code), but matches "git log" and "git log --raw" > output, and misses nothing that git has ever generated. And it extends > naturally to: > > if (!skip_prefix(author, "Commit: ", &v) && > !skip_prefix(author, "committer ", &v)) > continue; Yeah, I agree that the above long-hand would be more readable.