From: Junio C Hamano Date: Tue, 14 Feb 2023 22:34:01 GMT Subject: Re: [PATCH 3/3] shorten_unambiguous_ref(): avoid sscanf() Message-ID: In-Reply-To: Jeff King writes: > but I have a feeling that it gets more readable if we flip the break > conditional and the loop condition. Yeah, the somewhoat unusual loop structure was what motivated me to look at its corner case. Flipping the logic around may make it more straight forward.