From: Junio C Hamano Date: Thu, 22 Jun 2017 22:14:36 GMT Subject: Re: [PATCH 2/3] pack-objects: WIP add max-blob-size filtering Message-ID: In-Reply-To: <20170622145440.7609fa8b@twelve2.svl.corp.google.com> Jonathan Tan writes: > On Thu, 22 Jun 2017 20:36:14 +0000 > Jeff Hostetler wrote: > >> +static signed long max_blob_size = -1; > > FYI Junio suggested "blob-max-bytes" when he looked at my patch [1]. > > [1] https://public-inbox.org/git/xmqqmv9ryoym.fsf@gitster.mtv.corp.google.com/ To give credit to where credit is due, I learned this from akpm. When you are tempted to say "size", "length", "weight", etc., if you think of a way to phrase it with a more concrete unit, you'd end up with a much less ambiguous name. People can imagine max_blob_size is counted in kilobytes, or megabytes, or whatever. There is no room in max_blob_bytes to be interpreted in multiple ways.