From: Junio C Hamano Date: Tue, 24 Nov 2020 21:16:42 GMT Subject: Re: [PATCH] t3404: do not depend on any specific default branch name Message-ID: In-Reply-To: "Johannes Schindelin via GitGitGadget" writes: > From: Johannes Schindelin > > Now that we can override the default branch name in the tests via > `GIT_TEST_DEFAULT_INITIAL_BRANCH_NAME`, we should avoid expecting a > particular hard-coded name. > > So let's rename the initial branch immediately to `primary` and work > with that. Yes, that is probably the approach that gives us the most stable environment to work in. I like it. > Applying this patch would obsolete the change in > js/default-branch-name-tests-final-stretch to force the default branch > name to master in t3404. Yup, after taking these individual replacement patches, I expect that the big topic will see shrinkage, which is good. Will queue. Thanks.