From: Junio C Hamano Date: Mon, 14 Dec 2020 23:16:07 GMT Subject: Re: [PATCH v7 3/5] pull: get rid of unnecessary global variable Message-ID: In-Reply-To: <5fd7d22ceec2b_d4113208c1@natae.notmuch> Felipe Contreras writes: > Junio C Hamano wrote: >> It is easy enough to do, > > Yes. > >> gives a more descriptive name to the variable, > > I disagree. > >> and there is no reason to make the code deliberately worse by ignoring >> improvement offered on the list. > > I doubt any person contributing to the mailing is making the code > deliberately worse. Oh, I doubt that you do so with what you send out. I am saying that you do so by not taking improvements. It wastes reviewers' time, raises noise ratio in the list traffic, and demotivates readers.