From: Junio C Hamano Date: Wed, 03 Mar 2021 06:26:24 GMT Subject: Re: [PATCH v3 1/6] sequencer: export subject_length() Message-ID: In-Reply-To: Eric Sunshine writes: > On Mon, Mar 1, 2021 at 3:50 AM Charvi Mendiratta wrote: >> This function can be used in other parts of git. Let's move the >> function to commit.c. >> >> Signed-off-by: Charvi Mendiratta >> --- >> diff --git a/commit.h b/commit.h >> @@ -165,6 +165,9 @@ const void *detach_commit_buffer(struct commit *, unsigned long *sizep); >> +/* Return length of the commit subject from commit log message. */ >> +size_t subject_length(const char *body); > > Now that this function is public, is the name too generic? Most other > functions in this header have "commit" in the name. So, > commit_subject_length() might be one possibility (assuming the current > name is too generic). Thanks for being a careful reviewer, as always.