From: Junio C Hamano Date: Tue, 08 Sep 2015 22:46:23 GMT Subject: Re: [PATCHv5 3/3] submodule: Reimplement `module_clone` shell function in C Message-ID: In-Reply-To: Stefan Beller writes: > On Thu, Sep 3, 2015 at 3:07 PM, Junio C Hamano wrote: >>> + >>> + cp.no_stdin = 1; >>> + cp.no_stdout = 1; >>> + cp.no_stderr = 1; >> >> Output from "git clone" is not shown, regardless of --quiet option? > > Removed that. > >>> + argc = parse_options(argc, argv, prefix, module_clone_options, >>> + git_submodule_helper_usage, 0); >>> + >>> + strbuf_addf(&sb, "%s/modules/%s", get_git_dir(), name); >> >> The original says >> >> base_name=$(dirname "$name") >> ... > Slashes are already in use for submodule names as the name defaults > to the path if no explicit name is given. Ahh, OK, that base_name thing is so that "mkdir -p" can create a surrounding directory without creating the final level, which is left for 'git clone" to prepare. I misread the code. Thanks.