From: Junio C Hamano Date: Fri, 30 Jan 2026 21:56:11 GMT Subject: Re: [PATCH] revisions: add @{default} shorthand for default branch Message-ID: In-Reply-To: <20260130205830.45806-1-haraldnordgren@gmail.com> Harald Nordgren writes: > I pushed a WIP with some of these ideas now, not intended as the final > thing. > > > Harald Meaning we should feel free to ignore v3 and possibly a few later versions, until we hear from you? I was writing the following as v3 review, but I guess these are comments on a version not for public consumption, so ... --- >8 --- I'd rather not see you use "primary" for what init.defaultBranch specifies, which already has a good name, "default". If you are using a different concept, like: * learn the remote @{upstream} for the current branch (for "@{primary}") or the named branch (for "$name@{primary}"), and then * look at refs/remotes/$remote/HEAD then I would appreciate a good name to call that (which is a concept that has no good name yet, as far as I can see) and "primary" might be a good name for that new concept. And from what I read as _your_ use case in an earlier message, init.defaultBranch aka @{default} is not what you want 999/1, yet I think what the patch implements is still that one. Puzzled...