From: Junio C Hamano Date: Thu, 10 Oct 2019 02:51:13 GMT Subject: Re: [RFC WIP PATCH 2/3] tag: factor out prepare tag template code Message-ID: In-Reply-To: <20191008184727.14337-3-lucasseikioshiro@gmail.com> Lucas Oshiro writes: > Improve code readability by moving tag body reading to a new function called > get_tag_body. Quite honestly, I think the result of this splitting is harder to follow than the original. For example, the value of opt->message_given and the validity of given_msg is very closely related, so if you made the helper function receive non-NULL given_msg when !opt->message_given, the helper could only check !given_msg without having to worry about opt->message_given; with such a change, I could buy that the split improves code readability, but I do not see any such change in the patch. > Enhance legibility by encapsulating code that loads previous tag message > (if any) in new function prepare_tag_template.... The helper seems to be used to _write_ into path, and not load or read any message from either an object or a file on disk.