From: Junio C Hamano Date: Thu, 08 Feb 2024 17:33:08 GMT Subject: Re: [PATCH v2 2/4] oidset: refactor oidset_insert_from_set() Message-ID: In-Reply-To: <20240208135055.2705260-3-christian.couder@gmail.com> Christian Couder writes: > In a following commit, we will need to add all the oids from a set into > another set. In "list-objects-filter.c", there is already a static > function called add_all() to do that. > > Let's rename this function oidset_insert_from_set() and move it into > oidset.{c,h} to make it generally available. > > While at it, let's remove a useless `!= NULL`. Makes sense. My initial reaction was that copying underlying bits may even be more efficient, but that was only because silly-me did not realize that dst can be non-empty when the operation starts. The name of the function is not "copy oidset" but "insert from set" that makes it crystal clear what is going on. Good.