From: Junio C Hamano Date: Tue, 28 Jul 2020 21:18:05 GMT Subject: Re: [PATCH 11/11] strvec: rename struct fields Message-ID: In-Reply-To: Junio C Hamano writes: >> I'm actually not that fond of "items". I almost went with just: >> >> const char **v; >> >> as the variable name which contains it usually provides sufficient >> context. But I worried that people would consider that too inscrutable. > > I'd agree that v[] is a good name. If it is too short, I can live > with item[], but not with items[].... What are individual component of a vector called? An element? If so, elem[] would be much better name than item[].