From: Junio C Hamano Date: Mon, 26 Sep 2022 23:02:49 GMT Subject: Re: [PATCH] read-cache: avoid misaligned reads in index v4 Message-ID: In-Reply-To: Jeff King writes: > I do find it a bit more straight-forward, but the extra copy is ugly, > plus the "yuck" comment. Yeah, the "yuck" memcpy() is, eh, unfortunate. Consistently using a single "pointer" (pos) to keep track of where we are does make the structure of the code appear uniform and easier to follow, though.