From: Junio C Hamano Date: Thu, 04 Sep 2025 16:43:19 GMT Subject: Re: [PATCH v4] alloc: fix dangling pointer in alloc_state cleanup Message-ID: In-Reply-To: ノウラ | Flare writes: > The point of the check was to avoid subtle crashes > aligning with defensive programming requirements. It is a programming error, period. Do not silently return. That's not being defensive. That is sweeping a problem under the rug. We can always do assert() or if (condition) BUG("...") if we are unsure about the ability of our developers to grok subtle pre-conditions to call into certain code paths, and I would call that defensive. But I do not see a need for _this_ particular call. Our developers should be able to see what they are supposed to call it with just fine. Thanks.