From: Junio C Hamano Date: Mon, 09 Apr 2018 09:36:55 GMT Subject: Re: [RFC PATCH 1/1] completion: load completion file for external subcommand Message-ID: In-Reply-To: <20180409072909.GA30684@arbeitsviech> Florian Gamböck writes: > Good point. I could go even further and ditch the if-construct: > > ! declare -f $completion_func && declare -f __load_completion && > __load_completion "git-$command" I personally find that a lot harder to read than if/then/fi.