From: Junio C Hamano Date: Thu, 06 Jun 2024 17:24:18 GMT Subject: Re: [PATCH v2] apply: add unit tests for parse_range Message-ID: In-Reply-To: "Philip Peterson via GitGitGadget" writes: > From: Philip Peterson > > Also rename parse_range to parse_fragment_range for external linkage. > > Signed-off-by: Philip Peterson > --- This version saw no reviews (unfortunately). I just gave another quick glance, did not spot anything glaringly wrong, and the way the tests are organized as a series of ... > + TEST(setup_static((struct test_case) { > + .line = "@@ -4,4", > + .offset = -1, > + .expect_suffix = " +", > + .expect_result = FAILURE, > + .expect_p1 = 9999, > + .expect_p2 = 9999 > + }), "negative offset"); ... rather pleasant to read. I'd admit that it does not count as a proper review, though. Thanks.