From: Junio C Hamano Date: Thu, 01 Feb 2024 18:57:39 GMT Subject: Re: [PATCH v3 06/10] trailer: spread usage of "trailer_block" language Message-ID: In-Reply-To: <0a9a7438c3ff39f1434087bf3ed6a9865758c803.1706664145.git.gitgitgadget@gmail.com> "Linus Arver via GitGitGadget" writes: > From: Linus Arver > > Deprecate the "trailer_info" struct name and replace it with > "trailer_block". The main reason is to help readability, because > "trailer_info" on the surface sounds like it's about a single trailer > when in reality it is a collection of contiguous lines, at least 25% of > which are trailers. Yup, "info" is usually a fairly meaningless word. At least "block" may imply it is a collection of trailers. The naming would not matter as much to the API users, if the thing is now opaque, though.