From: Junio C Hamano Date: Tue, 07 Jan 2025 18:53:46 GMT Subject: Re: [PATCH v8 5/6] transport: add client support for object-info Message-ID: In-Reply-To: Calvin Wan writes: > Thanks for picking up this series btw! > ... > I think we can flatten this logic a bit more here to make it more intuitive. > > if (!unsorted_string_list_has_string(args->object_info_options, reader->line)) > return -1; > if (!strcmp(reader->line, "size")) { > size_index = i; > for (size_t j = 0; j < args->oids->nr; j++) > object_info_data[j].sizep = xcalloc(1, sizeof(long)); > } Indeed the updated code structure gets easier to follow. Thanks, both of you.