From: Junio C Hamano Date: Fri, 21 Aug 2015 16:51:41 GMT Subject: Re: [PATCH 3/3] am: rename "struct tree_desc t" to "desc" for readability Message-ID: In-Reply-To: <1440144151-24026-3-git-send-email-davvid@gmail.com> David Aguilar writes: > Signed-off-by: David Aguilar > --- > builtin/am.c | 8 ++++---- > 1 file changed, 4 insertions(+), 4 deletions(-) Naming the tree_desc parameter given to unpack_trees() as "t" is (unfortunately) an established convention, just like we often use "i" and "j" in for() loop control. Descriptive names are nicer, especially on the calling sites, but we have quite a many hits from $ git grep unpack_trees\( \*.c so perhaps do this as a clean-up patch after dust settles for all the existing callers in archive, clone, commit, merge, read-tree, reset, diff-lib, and merge-recursive?