From: Junio C Hamano Date: Tue, 27 Sep 2016 17:35:59 GMT Subject: Re: [PATCH v2 2/5] ref-filter: add function to print single ref_array_item Message-ID: In-Reply-To: <20160926224233.32702-3-santiago@nyu.edu> santiago@nyu.edu writes: > From: Lukas P > > ref-filter functions are useful for printing git object information > using a format specifier. However, some other modules may not want to use > this functionality on a ref-array but only print a single item. > > Expose a format_ref function to create, pretty print and free individual > ref-items. > > Signed-off-by: Lukas P > --- > +void format_ref(const char *name, const unsigned char *sha1, const char *format, > + unsigned kind) > +{ > + struct ref_array_item *ref_item; > + ref_item = new_ref_array_item(name, sha1, 0); > + ref_item->kind = kind; > + show_ref_array_item(ref_item, format, 0); > + free_array_item(ref_item); > +} > + > /* If no sorting option is given, use refname to sort as default */ > struct ref_sorting *ref_default_sorting(void) > { > diff --git a/ref-filter.h b/ref-filter.h > index 14d435e..1ef7999 100644 > --- a/ref-filter.h > +++ b/ref-filter.h > @@ -107,4 +107,8 @@ struct ref_sorting *ref_default_sorting(void); > /* Function to parse --merged and --no-merged options */ > int parse_opt_merge_filter(const struct option *opt, const char *arg, int unset); > > +/* Pretty-print a single ref */ > +void format_ref(const char *name, const unsigned char *sha1, const char *format, > + unsigned kind); The fact that you felt a need for comment before its name is a strong sign that the name is not sufficiently descriptive and understandable for readers to tell what the function is for. Would pretty_print_ref() or show_ref_pretty() better names, perhaps?