From: Junio C Hamano Date: Fri, 23 Mar 2018 17:19:33 GMT Subject: Re: [PATCH v2 3/5] fast-import: update pool_* functions to work on local pool Message-ID: In-Reply-To: <20180323144408.213145-4-jamill@microsoft.com> Jameson Miller writes: > Update memory pool functions to work on a passed in mem_pool instead of > the global mem_pool type. This is in preparation for making the memory > pool logic reusable. This should be part of 2/5; the same comments to 2/5 I just sent out would still apply to a patch that is a combined result between 2/5 and 3/5. Also, if mem_pool_alloc_block() etc. are the desired final names, using them from the beginning would make the result easier to read through (both during review and later "log -p"). Thanks. This round, especially 2/5 (with anticipation of 3/5 already in reader's head), was easier to grok than the previous.