From: Junio C Hamano Date: Thu, 02 Apr 2020 18:26:11 GMT Subject: Re: [PATCH v6 0/7] New proc-receive hook for centralized workflow Message-ID: In-Reply-To: <20200402163520.1338-1-worldhello.net@gmail.com> Jiang Xin writes: > From: Jiang Xin > > ## Changes since v5 > > + Fixed code review issues on v5. > > * s/cannot to/cannot/ > > * s/FLEX_ALLOC_MEM/FLEX_ALLOC_STR/ OK > * Add flag `C_LOCALE_OUTPUT` on test cases which may break > gettext-poison test. We prefer to avoid the C_LOCALE_OUTPUT prerequiste when we can use test_i18n to make the poison test not care. If it is too hard to arrange in these tests, it is OK to omit, though. > * Note: `rp_errors()` in "receive-pack" is executed on the > server side, I think leave them unmarked for i18n is better. Hmph, I vaguely recall saying something similar and then got a disagreement from somebody. Perhaps Jonathan (cc'ed)? Thanks.