From: Junio C Hamano Date: Mon, 27 Sep 2021 16:48:44 GMT Subject: Re: [PATCH v2 8/8] hook-list.h: add a generated list of hooks, like config-list.h Message-ID: In-Reply-To: Ævar Arnfjörð Bjarmason writes: > +sed -n \ > + -e '/^~~~~*$/ {x; s/^.*$/ "&",/; p;}' \ > + -e 'x' \ > + + LC_ALL=C sort Thanks. It is not wrong per-se, but if you are willing to do a multi-line script for readability, wouldn't a much more readable "single long and multi-line string" approach, i.e. sed -ne ' /^~~~~*$/ { x s/^.*$/ "&",/ p } x ' Documentation/githooks.txt | LC_ALL=C sort work better?