From: Junio C Hamano Date: Tue, 02 Apr 2024 17:23:43 GMT Subject: Re: [PATCH v3 1/3] reftable/stack: add env to disable autocompaction Message-ID: In-Reply-To: Patrick Steinhardt writes: >> - if (!add->stack->disable_auto_compact) >> + if (!add->stack->disable_auto_compact && !git_env_bool("GIT_TEST_REFTABLE_NO_AUTOCOMPACTION", 0)) >> err = reftable_stack_auto_compact(add->stack); > > The double-negation in `GIT_TEST_REFTABLE_NO_AUTOCOMPACTION=false` may be > somewhat hard to parse. Should we rename this to > `GIT_TEST_REFTABLE_AUTO_COMPACTION` with a default value of `1`? Sounds like a nice improvement. Also the overlong line should be folded. Thanks.