From: Junio C Hamano Date: Mon, 09 Sep 2024 18:17:43 GMT Subject: Re: [PATCH v8 10/14] Makefile: wire up the clar unit testing framework Message-ID: In-Reply-To: <9c74c5ae01989659c0347d2742f820d2161d274b.1725459142.git.ps@pks.im> Patrick Steinhardt writes: > +UNIT_TESTS_PROG = $(UNIT_TEST_BIN)/unit-tests$(X) > +UNIT_TESTS_OBJS = $(patsubst %,$(UNIT_TEST_DIR)/%.o,$(UNIT_TESTS_SUITES)) > +UNIT_TESTS_OBJS += $(UNIT_TEST_DIR)/clar/clar.o > +UNIT_TESTS_OBJS += $(UNIT_TEST_DIR)/unit-test.o > + > UNIT_TEST_PROGRAMS += t-ctype > UNIT_TEST_PROGRAMS += t-example-decorate > UNIT_TEST_PROGRAMS += t-hash > @@ -2714,6 +2721,7 @@ OBJECTS += $(XDIFF_OBJS) > OBJECTS += $(FUZZ_OBJS) > OBJECTS += $(REFTABLE_OBJS) $(REFTABLE_TEST_OBJS) > OBJECTS += $(UNIT_TEST_OBJS) > +OBJECTS += $(UNIT_TESTS_OBJS) What is the longer term direction we envision? Do we aim to retire the UNIT_TEST_* and end up with only the clar based tests? At least until that happens, can we have "UNIT_TESTS" -> "CLAR_TEST" or something that makes it less confusing? Every time I see merge conflicts around this area in the Makefile, I get puzzled and wonder which one is which. Thanks.