From: Junio C Hamano Date: Thu, 04 Mar 2021 20:28:20 GMT Subject: Re: [PATCH v4 03/12] pkt-line: (optionally) libify the packet readers Message-ID: In-Reply-To: Jeff King writes: > I think the flag is doing sensible things; it's just that the word > "never" in the name is confusing, since it is "never except this one > time". > > Would PACKET_READ_GENTLE_ON_READ_ERROR be a better name, to match > GENTLE_ON_EOF? I was tempted to just call it "ON_ERROR", since it also > include parsing errors, but maybe somebody would think that includes ERR > packets (that is more of a stretch, though, I think). > > Likewise, I kind of wonder if callers would really prefer suppressing > the error() calls, too. Saying "error: the remote end hung up > unexpectedly" is not that helpful if the "remote end" we are talking > about is fsmonitor, and not the server side of a fetch. Both sounds sensible.