From: Junio C Hamano Date: Sat, 05 Jun 2021 13:15:52 GMT Subject: Re: [ANNOUNCE] Git v2.32.0-rc3 - t5300 Still Broken on NonStop ia64/x86 Message-ID: In-Reply-To: <9b663ba3-6680-0d9a-4910-502cb2abac6b@web.de> René Scharfe writes: > The function body can be written like this: > > while (fsync(fd) < 0) { > if (errno != EINTR) > die_errno("fsync error on '%s'", msg); > } > > I find it easier to read because it has less syntax elements > and is shorter. Bikeshedding, of course. :-/ It indeed is easier to follow. Thanks.