From: Junio C Hamano Date: Thu, 06 Jun 2024 16:18:30 GMT Subject: Re: [PATCH v5 00/12] refs: ref storage migrations Message-ID: In-Reply-To: Patrick Steinhardt writes: > Hi, > > the ref storage migration was merged to `next`, but got reverted due to > some additional findings by Peff and/or Coverity. > > Changes compared to v4: > > - Adapt comment of `ref_store_init()` to the new parameter. > > - Fix use of an uninitialized return value in `for_each_root_ref()`. > > - Fix overwrite of ret code in `files_ref_store_remove_on_disk()`. > > - Adapt an error message to more clearly point out that deletion of > "refs/" directory failed in `reftable_be_remove_on_disk()`. > > - Fix a leak when `mkdtemp()` fails. > > Thanks! > > Patrick Looking good. The use of strbuf for mkdtemp() template and relying on the fact that mkdtemp() makes an in-place modification of the template string made the resulting code easier to follow, I would think. Let's mark the topic ready for 'next'. Thanks.