From: Junio C Hamano Date: Tue, 16 Aug 2016 19:06:52 GMT Subject: Re: [PATCH v3] help: make option --help open man pages only for Git commands Message-ID: In-Reply-To: Ralf Thielow writes: > 2016-08-16 19:27 GMT+02:00 Junio C Hamano : >> Ralf Thielow writes: >>> + >>> + if (swapped) >>> + return help_unknown_cmd(cmd); >> >> I am guilty of suggesting "swapped"; even if we are going to mark >> this as OPT_HIDDEN, I think we should be able to think of a better >> name. I think the meaning of this boolean is "we know that this is >> not a guide and is meant to be a command.", and I hope we can come >> up with a name that concisely expresses that (e.g. "--not-a-guide", >> "--must-be-a-command"). >> > > I think "--cmd-only" is a good name. With a good name I think it's worth > to make this option visible to the user. Sure. I'd prefer "cmd" to be spelled out in anything that is end-user facing, though.