From: Junio C Hamano Date: Fri, 03 Jun 2022 00:37:25 GMT Subject: Re: [PATCH v3 1/2] run-command API: rename "env_array" to "env" Message-ID: In-Reply-To: Ævar Arnfjörð Bjarmason writes: > The rest of this is all a result of applying [1]: > > * make contrib/coccinelle/run_command.cocci.patch > * patch -p1 * git add -u > > 1. cat contrib/coccinelle/run_command.pending.cocci > @@ > struct child_process E; > @@ > - E.env_array > + E.env > > @@ > struct child_process *E; > @@ > - E->env_array > + E->env It makes sense to have this in the log message for documentation purposes. We have plenty of examples of renaming a symbol to another, like the simple ones in object_id.cocci, so adding this to the collection in contrib/coccinelle would not add much value. Will replace. Thanks.