From: Junio C Hamano Date: Thu, 11 Dec 2014 21:42:23 GMT Subject: Re: [PATCH 2/8] refs.c: rename the transaction functions Message-ID: In-Reply-To: <1417833995-25687-3-git-send-email-sbeller@google.com> Stefan Beller writes: > Rename the transaction functions. Remove the leading ref_ from the > names and append _ref to the names for functions that create/delete/ > update sha1 refs. > > The goal in the long term is to have different things running through > the transaction api, such as the .git/config file. > > The dream is to... I was trying to polish somebody else's topic that does not have anythning to do with refs/reflogs/transactions today, and had to suffer from conflicts from the textual difference between transaction_begin and ref_transaction_begin, which I feel is totally unnecessary at this moment. I'd really prefer to see this done long after all the dust from "ref" changes from various people have settled, especially given that we are not doing anything for that "dream" right now. Thanks.