From: Junio C Hamano Date: Fri, 25 Sep 2015 15:50:07 GMT Subject: Re: [PATCH] t5561: get rid of racy appending to logfile Message-ID: In-Reply-To: <1443118342-3856-1-git-send-email-s-beyer@gmx.net> Stephan Beyer writes: > The definition of log_div() appended information to the web server's > logfile to make the test more readable. However, log_div() was called > right after a request is served (which is done by git-http-backend); > the web server waits for the git-http-backend process to exit before > it writes to the log file. When the duration between serving a request > and exiting was long, the log_div() output was written before the last > request's log, and the test failed. (This duration could become > especially long for PROFILE=GEN builds.) > > To get rid of this behavior, we should not change the logfile at all. > This commit removes log_div() and its calls. The additional information > is kept in the test (for readability reasons) but filtered out before > comparing it to the actual logfile. > > Signed-off-by: Stephan Beyer > --- > Okay Peff, I added the information to the commit message (in my own > words). Past tense for the situation before the patch, present tense > for the situation after (hope that's right but should not be too > important). > > I also used your proposed grep line because it is probably more robust. Thanks, both. I vaguely recall this test mysteriously failing a few times during the past several years for me. Thanks for digging to the bottom of the problem. Both the diagnosis and fix look very sensible.