From: Junio C Hamano Date: Tue, 09 Aug 2016 15:51:09 GMT Subject: Re: [PATCHv3 1/9] t7408: modernize style Message-ID: In-Reply-To: Junio C Hamano writes: > Eric Sunshine writes: > >> On Tue, Aug 9, 2016 at 12:08 AM, Stefan Beller wrote: >>> t7408: modernize style >>> >>> Signed-off-by: Stefan Beller >>> --- >>> diff --git a/t/t7408-submodule-reference.sh b/t/t7408-submodule-reference.sh >>> @@ -8,74 +8,76 @@ test_description='test clone --reference' >>> +test_expect_success 'that reference gets used with add' ' >>> + ( >>> + cd super/sub && >>> + echo "0 objects, 0 kilobytes" > expected && >> >> Since you're modernizing the style, perhaps drop the space after '>' >> here and elsewhere. >> >>> + git count-objects > current && >>> + diff expected current >> >> Modern practice is to call this 'actual' rather than 'current', but >> perhaps that's outside the scope of this patch(?). > > Not just that, modern practice is to use "test_cmp" not "diff". Sorry, hit the "send" too soon, before writing "But all of that comes in the next step."