From: Junio C Hamano Date: Tue, 29 Oct 2013 19:54:16 GMT Subject: Re: [PATCH] commit: Add -f, --fixes option to add Fixes: line Message-ID: In-Reply-To: Christian Couder writes: > On Mon, Oct 28, 2013 at 10:08 AM, Junio C Hamano wrote: >> >> Thinking aloud further, what I had in mind was along the lines of >> the following. >> >> * The most generic external interface would be spelled as >> >> --trailer [=] >> >> where can be things like "signoff", "closes", "acked-by", >> "change-id", "fixes", etc.; they can be taken from an unbounded >> set. The historical "--signoff" can become a short-hand for >> "--trailer signoff". More than one "--trailer" option can be >> given on a single command line. > > Ok, and maybe the could also be the full trailer like "Signed-off-by". Yeah, between these two: [commitTrailer "Signed-off-by"] style = append-norepeat shorthand = signoff command = echo "$GIT_COMMITTER_NAME <$GIT_COMMITTER_EMAIL>"' [commitTrailer "signoff"] style = append-norepeat trailer = Signed-off-by command = echo "$GIT_COMMITTER_NAME <$GIT_COMMITTER_EMAIL>"' I do not have strong preference either way. One of these two sets of configuration will have to become a built-in default (i.e. still allowing people from other development community conventions to redefine how S-o-b: works), so there will be no user-visible difference either way at the highest-level Porcelain anyway. Oh, also, it seems people prefer to call them "footers", judging by the messages in this thread. I do not have a problem with that word, either; I suspect we may have to update existing documentation that calls them "trailers", if we go that way, though.