From: Junio C Hamano Date: Mon, 21 Dec 2020 19:00:21 GMT Subject: Re: [PATCH v3 1/3] test-lib-functions: handle --add in test_config Message-ID: In-Reply-To: Eric Sunshine writes: > Finally, as this is a one-off case, it might be simpler just to drop > this patch altogether and open-code the cleanup in the test itself in > patch [2/3] rather than bothering with test_config() in that > particular case. For example: > > test_when_finished "test_unconfig -C two remote.one.push" && > git config -C two --add remote.one.push : && > test_must_fail git -C two push one && > git config -C two --add remote.one.push ^refs/heads/master && > git -C two push one That would be my preference, too. Thanks for carefully and patiently reviewing.