From: Junio C Hamano Date: Tue, 18 Feb 2025 17:09:05 GMT Subject: Re: [PATCH v6 0/6][Outreachy] extend agent capability to include OS name Message-ID: In-Reply-To: <20250215155130.1756934-1-usmanakinyemi202@gmail.com> Usman Akinyemi writes: > Changes since v5 > ================ > - Used "-" instead of " " for seperating "version" and "os" in the agent string. > > Usman Akinyemi (6): > version: replace manual ASCII checks with isprint() for clarity > version: refactor redact_non_printables() > version: refactor get_uname_info() > version: extend get_uname_info() to hide system details > t5701: add setup test to remove side-effect dependency > agent: advertise OS name via agent capability Overall everything looks good. I spotted just one nit in the protocol documentation update, which I'll comment on separately. Thanks.